Yes. What version we can update you to, or older version you want to downgrade to, may depend on the operating system version on the server. Older operating systems will not run the newer versions of PHP or MySQL, and later operating systems will not run all the older versions.